[gelös]QtCreator kde-libs einbinden

Alles zu Entwicklungsumgebungen und Editoren für Qt
Antworten
sfbeetle
Beiträge: 9
Registriert: 13. September 2017 12:55

[gelös]QtCreator kde-libs einbinden

Beitrag von sfbeetle » 2. Oktober 2017 11:56

update am 04.10.17

OpenSuse Leap 42.3
KDE-Plasma-Vers. 5.8.7 -> 5.10.85
KDE-Framework 5.38.0
Qt-Version 5.9.1.
QtCreator 4.4.0

Mein Projekt wird ohne Fehler kompiliert.Bis zum Versuch mit einer externen Bibliothek zu arbeiten.
Keinerlei Fehlerhinweis beim einbinden von Poppler 0.43.0-5.1 als externe Bibliothek
pro-Datei:

Code: Alles auswählen

unix:!macx: LIBS += -L$$PWD/../../../usr/lib64/ -lpoppler-qt5

INCLUDEPATH += $$PWD/../../../usr/include/poppler/qt5
DEPENDPATH += $$PWD/../../../usr/include/poppler/qt5

Beim nächsten kompilieren wird mit
"simpleOCR-Desktop-Debug/simpleOCR': realloc(): invalid pointer: 0x00000000006113e0***"
und vielen Folgefehlern, sowie

"The process was ended forcefully."
abgebrochen.
wenn ich ohne den Zusatz nur die poppler.so einbinde

Code: Alles auswählen

unix:!macx: LIBS += -L$$PWD/../../../usr/lib64/ -lpoppler

INCLUDEPATH += $$PWD/../../../usr/include/poppler/qt5
DEPENDPATH += $$PWD/../../../usr/include/poppler/qt5

"undefined reference to `Poppler::Document::load(QString const&, QByteArray const&, QByteArray const&)'"
und
":-1: Fehler: collect2: error: ld returned 1 exit status"
Lt. google beides ein Hinweis, daß die lib nicht ordnungsgemäß oder garnicht eingebunden ist.

Auf meinem Rechner befinden sich folgende Poppler-Pakete:

libpoppler-cpp0 libpoppler-devel libpoppler-glib-devel
libpoppler-glib8 libpoppler-qt4-4 libpoppler-qt4-4-devel
libpoppler-qt5-1 libpoppler-qt5-devel libpoppler60
poppler-data poppler-tools typelib-1_0-Poppler-0_18

Frage 1) welche lib sollte eingebunden sein poppler.so oder poppler-qt5.so ?
Frage 2) welche pakete werden mind. benötigt und welche stören evtl. nur?
Frage 3) Haben evtl. die poppler-pakete die falsche Version? - denn vor einem Crash funktionierte das einbinden externer Bibliotheken
mit Creator 4.3 und etwas älteren qt- und Plasma- Versionen problemlos?

Ich hoffe jemand kann mir sagen , welche Einstellungen und welche Qt-lib kontrollieert werden sollten.

vorab vielen Dank

sfbeetle

In der Standartinstallation von OpenSuse Leap 42.3 verlinkt der Creator auf qmake.. Ich habe den Pfad auf qmake-qt5. geändert.

Antworten