Icons verschwunden

Verschiedenes zu Qt
Antworten
TheRat101
Beiträge: 1
Registriert: 2. März 2018 22:10

Icons verschwunden

Beitrag von TheRat101 » 2. März 2018 22:27

Hallo Leute,

ich habe viele Beiträge zu diesem Thema gesehen leider finde ich keines welches auf mein Problem zutrifft.
Zuzusagen ist das ich gerade erst in QT eingestiegen bin.

Ich habe mit QT Designer ein UI erstellt mit Toolbar. Sowohl die Menüleiste mit Ihren Auswahlen als auch die Toolbar besitzen Icons welche über eine Ressourcendatei eingebunden wurden. Die Einbindung der Icons wurde auch im Designer über die Objekteigenschaften > Icon > Thema gesetzt.

Es lief alles Problemlos bis ich mit der Programmierung der Schaltflächen begonnen habe.
Ab diesen Zeitpunkt verschwanden die Icons.

- im Designer: Icons werden nicht mehr angezeigt
- im Designer in der "Icon > Thema" Einstellung wird sowhol das Icon angezeigt als auch der korrekte Pfad zum Bild (z.B. :/img/cut-icon.png)
- nach dem Debugbuild im laufendem Programm: Icons werden nicht mehr angezeigt

Ich habe bereits versucht die Programmierung zurück auf Rohzustand zu setzen (indem ich den hinzugefügten Code entfernte), sowie die ressourcen Datei neu einzubinden. Auch diverse Neustarts des Computers als auch löschen der Debug-Dateien und neu Builden haben nichts gebracht.
Sobald ich im Code die Icons manuell "anzwinge" mit ui->actionAusschneiden->setIcon(QIcon(":/img/cut-icon.png")); wird das Icon wieder Problemlos angezeigt.

Da ich gerade nicht wirklich weiß wo ich ansetzen soll, würde ich mich freuen wenn Ihr mir sagt welche Informationen Ihr benötigt.

Vielen Dank im voraus
Liebe Grüße

Christian81
Beiträge: 7281
Registriert: 26. August 2004 14:11
Wohnort: Bremen
Kontaktdaten:

Re: Icons verschwunden

Beitrag von Christian81 » 4. März 2018 09:40

Linkst Du statisch?
Ansonsten - ein minimales, kompilierbares Beispiel wäre nicht schlecht (am besten als zip-Datei da es ja mehrere Dateien sind)
MfG Christian

'Funktioniert nicht' ist keine Fehlerbeschreibung

Antworten