KDevelop 3.0.2 SuSE 9.1 upgrade von SuSE 8.1 Uebernahme

Alles zur Entwicklung von KDE - Anwendungen
microdigi
Beiträge: 3
Registriert: 8. September 2004 12:34
Wohnort: D-29559 Wrestedt
Kontaktdaten:

KDevelop 3.0.2 SuSE 9.1 upgrade von SuSE 8.1 Uebernahme

Beitragvon microdigi » 21. Oktober 2004 16:46

Hilfe / Info zur Unvertraeglichkeit.

Mit der Linux SuSE 9.1 habe ich natuerlich auch das neue KDevelop 3.0.2 installiert.
Leider hab ich mir damit einen ganz schoenen Sack Floehe eingehandelt offensichtlich.
Mit dem Vorgaenger von SuSE 8.1 habe ich ueber zwei Jahre einwandfrei gearbeitet,
kenne mich also 'ein wenig' aus.
Die neue Version ist nun eine Hutnummer groesser, und damit schiesst sie m.E. ueber das Ziel (leider) weit hinaus.
Das 'Ding' scheint mir derartig aufgeblasen zu sein,
dass (zuegiges) Arbeiten damit nicht mehr moeglicht ist.
Dieses Thema ist aber nicht Sinn dieser Frage hier.

Dieser Beitrag geht auch an Trolltech,
und ich werde ihn nicht uebersetzen obwohl englisch perfekt.
Ich weiss, dass bei Trolls auch Deutschsprachige arbeiten.
Gruss dort hin.

Status:
CVS brauche und benutz(t)e ich nicht,
Qt 3.3.3 gekaufte Lizenz-Version ist benutzt.
gcc 3.3.3 eingesetzt.

Ich dachte, die bestehende Projekt-Dateien einfach zu uebernehmen - und weiter gehts.
Das war nicht; denn es hat sich einfach 'alles' geaendert.
Leider sind auch die Tooltips nicht besonders hilfreich,
und das Manual (Help) ist nur halb fertig.
Und ich nehme mir mal so die Freiheit zu behaupten, dass es einfach unmoeglich ist,
sich durch die configs und makes durchzuwuehlen.
Es ist mir nicht gelungen, das Ding ans Laufen zu bringen.
Besonders der damalige (interne) Debugger mit Ein-Klick-Breakpoints und Bookmarks -
beides weg. Den Debugger hab ich bis heute nicht zum Laufen gebracht.

Kompilieren geht (einwandfrei?) und auch die Ausfuehrbare laeuft.
--enable-debug=full --enable-mt --enable-static -with-qtdir=/usr/lib/qt3

Bin aber natuerlich jetzt fuer jede brauchbare Hilfe dankbar.
Insbesondere wie ich den (integrierten?) Debugger wieder wie gewohnt ans Laufen bringe.

Sehr stoerend wirkt auch die komplett fehlende Tiled Windows-Anordnung der Source-Texte.
Die gabs damals wenigstens, wenn auch nur laestig ueber drei Ecken ausfuehrbar.

Der Versuch, auf die die vorige KDevelop (von SuSE 8.1) downzugraden
schlaegt fehl, weil SuSE YaST das nicht macht.
Also, ich KANN nicht mehr rueckwaerts. Weil eben noch viel mehr auf dem System laeuft.

PS: 40 Jahre intensivste IT- Erfahrung
also weiss ich wovon ich rede ?
Moeglichwerweise fehlt mir nur der richtige Einstieg / der Tick
zu einer Information wie man die Umstellung bewirkt.


Das System 9.1 ist eine hervorragende Leistung -Danke!

Aloha - danke - digi

Spring-Daniel
Beiträge: 40
Registriert: 4. Oktober 2004 16:26

Beitragvon Spring-Daniel » 22. Oktober 2004 18:13

Hier ein Troll: KDevelop hat doch mit Trolltech ansich garnichts am Hut? ( Naja, klar, Qt..., aber ansonsten? )

Ich denke, Deine Frage waere in einem KDevelop - bezogenem Forum besser aufgehoben. Zumal man mit den angegebenen Informationen auch nicht viel anfangen kann.

Trotzdem weiter viel Erfolg beim Anpassen deines neuen KDevelops...

Dave
Beiträge: 5
Registriert: 23. Oktober 2004 09:34

Kdevelop

Beitragvon Dave » 23. Oktober 2004 11:11

Hallo Microdigi,

ich habe auch mit Suse Linux 8.0, 8.2... angefangen.
Meine Meinung zu diesen "alten" Versionen:
"UNBEFRIEDIGEND" :twisted: :twisted:
Habe jetzt auf Suse Linux 9.1 gewechselt und ich muß sagen:
"SUPER" :D :D :D
Bei mir hat alles von Anfang an funktioniert (zum ersten mal!!!!)
....auch mit Kdev!
Ich finde sogar es läßt sich ziemlich intuitiv bedienen, obwohl ich
ein Newbie bezüglich Linux, QT und Cpp bin.
Damals wie heute ist meines Wissens der gleiche Debugger in Kdev vorhanden
nämlich Kdbg.
Die Bedienung ist prinzipiell die gleiche, nur das die neue Version
um einiges komfortabler ist.
Dein Problem besteht wahrscheinlich in einer meiner Meinung nach
vorhandenen Unzulänglichkeit von Kdev bei der Projektimportierung.
Dieses Prob ist mir aber schon bei den alten Versionen aufgefallen.
Wahrscheinlich fehlt bei Dir der folgende Eintrag in der QT'schen
*.pro Datei: CONFIG += qt debug
Aber, und das ist das Prob das mir schon immer aufgefallen ist:
Es genügt NICHT diesen Eintrag im Designer bei der Projekterstellung zu machen,
sondern Du MUSST diesen in Kdev nochmals kontrollieren und wenn nötig
händisch nachtragen.
Anschliessend alles wie gewohnt machen: qmake bzw Kdev: Projekt erstellen durchführen
und dann sollte Kdbg wie gewohnt mit EIN-KLICK-BREAKPOINTS funktionieren.

viel Glück
Dave

Dave
Beiträge: 5
Registriert: 23. Oktober 2004 09:34

Beitragvon Dave » 23. Oktober 2004 12:06

Hallo,

habe vorhin Newbie typisch was falsches behaubtet:

ZITAT:

"Dein Problem besteht wahrscheinlich in einer meiner Meinung nach
vorhandenen Unzulänglichkeit von Kdev bei der Projektimportierung."

Dem ist nicht so:
Habe soeben das alles nochmals kontrolliert.
Es scheint ein QT-Fehler zu sein.
Bei der Erstellung eines neuen Projektes im Designer
im Fenster "Project Settings" kann man unter anderem
CONFIG-Einträge machen.
Defaultmäßig ist "qt warn on_release" vorhanden.
Erweitert man diese Zeile um "qt debug" und speichert ab,
wird der zweite Eintrag nicht übernommen.
Fehlt dieser Eintrag ist kein Debugger in der Lage zu debuggen,
weil eben die gesamten Debuginfos fehlen.

SORRY :oops:

Gruß
Dave

microdigi
Beiträge: 3
Registriert: 8. September 2004 12:34
Wohnort: D-29559 Wrestedt
Kontaktdaten:

Beitragvon microdigi » 25. Oktober 2004 22:18

Bis heute ist das 'Problem' immer noch nicht geloest.
Sobald ich das im Griff habe,
wir das Ergebnis hier erscheinen.

Vielen Dank dafuer, dass Ihr euch Kopfschmerzen gemacht habt.

Gruss - digi

Noch eine Bemerkung:
KDE basiert sehr stark auf Qt
und zwar auf /usr/lib/qt3
Man nehme diese diretory mal raus
und versuche dann, X11 zu starten.

digizar
Beiträge: 3
Registriert: 10. September 2012 16:45
Wohnort: Bad Soden-Salmünster
Kontaktdaten:

Re: KDevelop 3.0.2 SuSE 9.1 upgrade von SuSE 8.1 Uebernahme

Beitragvon digizar » 11. September 2012 09:40

Das Problem wurde (für mich) 'gelöst' indem ich seinerzeit aus dem Projekt ausgestiegen bin. :lol:
http://digispics.com/Pers/resger2012.pdf


Zurück zu „KDE Programmierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast