Arbeiten mit Openmpi

Dein Thema passt einfach in kein Forum? Dann probiers mal hier.
Antworten
deliaophelia
Beiträge: 4
Registriert: 7. Juli 2011 17:50

Arbeiten mit Openmpi

Beitrag von deliaophelia » 16. Mai 2013 13:01

Hallo,
das einbinden von Openmpi führt bei mir immer zu einem Fehler. Openmpi ist installiert. Die mpi.h ist eingebunden und auch in der .pro sind QMAKES drin.
Hier mal die .pro Datei.

Code: Alles auswählen

QT       += core gui

greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

TARGET = Conways
TEMPLATE = app


SOURCES += main.cpp\
        mainwindow.cpp \
    gamewidget.cpp

HEADERS  += mainwindow.h \
    gamewidget.h \
    omp.h

FORMS    += mainwindow.ui

QMAKE_CXXFLAGS += -fopenmp
QMAKE_LFLAGS += -fopenmp


QMAKE_CC = mpicc
QMAKE_CXX = mpic++

QMAKE_CC = $$system(mpicc --showme:compile)
QMAKE_CXX = $$system(mpic++ --showme:compile)
QMAKE_LFLAGS = $$system(mpic++ --showme:link)
Als Fehler bekomme ich:
no such file or directory für main.o etc.

die Kompilierung gibt folgende Fehler aus:
sh: mpicc: command not found
sh: mpic++: command not found
sh: mpic++: command not found

Wisst ihr was noch fehlen könnte?

Christian81
Beiträge: 7319
Registriert: 26. August 2004 14:11
Wohnort: Bremen
Kontaktdaten:

Re: Arbeiten mit Openmpi

Beitrag von Christian81 » 16. Mai 2013 17:34

Es steht doch da was fehlt:

Code: Alles auswählen

sh: mpicc: command not found
sh: mpic++: command not found
MfG Christian

'Funktioniert nicht' ist keine Fehlerbeschreibung

Antworten